Главная страница | назад





Article #18800: Builder 3 with an S3 Virge chip

 Question and Answer Database

FAQ3800C.txt   Builder 3 with an S3 Virge chip
Category   :Install Issues
Platform    :Win95/NT
Product    :   All32Bit

Question:
I started up CBuilder 3, and it froze just after the
splashscreen, just as the component palette is loading up.

Answer:
We don't know the actual reason for this, yet, but we
believe that the problem is with the S3 driver and bitmap
caching.  We have been as yet unable to reproduce this 
in-house, so all information that can be given is welcome.

"Builder 3 is throwing up a lot of bitmaps at the
card at startup, and it's overflowing the internal driver 
bitmap cache."

These solutions change different things concerning
either the cache size or amount of data being thrown at
the cache:

1)  Get the latest driver (www.s3.com or your vendor).
2)  Start BCB3 with the -NS switch
3)  Play with color depth/resolution 1024x768 16-bit color
    seems to be the worst.
4)  Under the [display] section of the SYSTEM.INI file add
    the following line:
    BusThrottle=1
    (Then reboot)
5)  Reduce the hardware acceleration for the card.
6)  Get the latest DirectX drivers.  (Probably not
    necessary for Win98 systems).
7)  One person has found that no desktop wallpaper or a 
    wallpaper that is smaller in size worked for him.
8)  Try running Builder in Safe Mode and removing components
    that you won't use.  This will cause fewer bitmaps to be
    loaded during the startup.  We aren't yet sure if this will
    work, but we want to test it.  If you find that it works,
    please post to our builder install newsgroup.

12/30/99
 

Last Modified: 01-SEP-99